Главная Office Как посчитать среднее значение в Excel
0

Как посчитать среднее значение в Excel и найти правильный ответ

0

Как посчитать среднее значение в Excel? Выделите необходимую группу чисел, жмите на кнопку суммы на рабочей панели (∑), а в выпадающем списке жмите на «Среднее». При желании можно вручную вести параметр «=СРЗНАЧ» с указанием диапазона ячеек. Ниже рассмотрим, как правильно рассчитать параметр для разных случаев — с текстом, с условием, средневзвешенное и т. д.

Простой расчет

Наиболее простой метод, как вычислить среднее значение в Excel — сделать это с помощью специального значка на панели инструментов Майкрософт Эксель. Для этого сделайте следующее:

  1. Выделите группу числе в столбце, для которых нужно рассчитать среднее значение в Экселе.
  2. Перейдите в раздел «Главная».
  3. Найдите значок «∑» на рабочей панели в блоке редактирования.
  4. В выпадающем списке жмите на «Среднее».
  5. Получите результат, который выводится в качестве усредненного арифметического набора чисел.

Этот метод подходит легкостью и удобством применения, но у него имеются и недостатки. В частности, с его помощью можно подсчитать усредненный параметр для чисел, которые находятся в одном столбце / строке. Если же нужно работать с массивом данных или ячейками, которые находятся в разных участках, расчет среднего значения в Excel будет затруднен.

Альтернативный вариант — ручной ввод необходимой опции с помощью функции «СРЗНАЧ». Чтобы посчитать нужные данные, введите команду по следующему алгоритму: «=СРЗНАЧ(адрес_диапазона_ячеек(цифра); адрес_диапазона_ячеек(цифра)). Он не такой быстрый, как рассмотрен выше, но позволяет найти среднее число в Excel даже в сложных ситуациях.

Как посчитать для нескольких ячеек

Если нужно посчитать среднее значение в Excel для большой группы ячеек, можно использовать «Мастер функций». Он позволяет считать среднее значение в Excel с помощью озвученной выше формулы, но сам процесс проходит немного проще. Алгоритм действий следующий:

  • Кликните по ячейке, где нужно посчитать требуемое значение в Эксель.
  • Жмите на «Вставить функцию», находящуюся с левой стороны от строки формул или же кликните Shift+F3.

  • Запустите «Мастер функций», в перечне доступных опций найдите «СРЗНАЧ».
  • Выделите его и кликните на «ОК».

  • В графе «Число» укажите аргументы функции, а именно цифры или адреса секций, где они находятся. Для большего удобства кликните на клавишу, которая находится с правой стороны от поля ввода данных.

  • Выделите те ячейки, для которых нужно посчитать данные, а после кликните на клавишу с левой стороны от поля ввода данных для возврата к окну аргументов функции.

Если нужно высчитать среднее значение в Excel от цифр, которые расположены в разных ячейках, сделайте рассмотренные выше действия, но в графе «Число 2». Действовать нужно до тех пор, пока все группы не окажутся выделенными. Результат указывается в той ячейке, которая была выделена перед входом в «Мастер функций».

Через формулы

Следующий способ, как найти среднее значение в Excel — через формулы. Для запуска параметра «СРЗНАЧ» сделайте следующее:

  1. Кликните на раздел «Формулы».
  2. Выделите ячейку, где нужно получить результат.
  3. В секции «Библиотека функций» ленты кликните «Другие …».
  4. Кликните на «Статические» и «СРЗНАЧ».
  5. Выполните остальную работу по принципу, который рассмотрен выше.

Как посчитать с условием

Нередко возникает вопрос, как найти среднее арифметическое в Excel с помощью опции условия. В такой ситуации для расчета берутся лишь те цифры из диапазона, соответствующего определенному условию, к примеру, если параметр больше или меньше определенного числа.

Для такой опции применяется функция «СРЗНАЧЕСЛИ». Для ее запуска можно использовать три пути:

  1. «Панель формул».
  2. «Мастер функций».
  3. «Ручной ввод в ячейку».

После открытия окна аргументов остается ввести параметры, а в поле «Диапазон» ввести пределы ячеек, которые будут участвовать для определения среднего арифметического. Здесь принцип действия такой же, как в случае с обычным «СРЗНАЧ».

Чтобы в Экселе сделать среднее значение с условием, необходимо в графе «Условие» указать определенный параметр, в отношении которого будет осуществляться сравнение. К примеру, это может быть «<=10000». В этом случае можно посчитать данные для тех секций Excel, в которых находятся числа меньше или равные 10 000. Если это нужно, кроме определенной цифры можно указать адрес, где находится специальное число.

Графу «Диапазон усреднения» можно не заполнять. Вводить в нее данные обязательно только с применением ячеек с текстом. Как только все сведения указаны, кликните на «ОК». Среднее значение в Excel будет показано для определенного диапазона, кроме данных, которые не соответствуют заявленному условию.

С текстом

Бывают ситуации, когда необходимо посчитать среднее значение в Эксель вместе с текстом. В этом случае используется функция, имеющая следующий вид: =СРЗНАЧЕСЛИ($A$2:$A$13;A7;$B$2:$B$13). Здесь в графа «А» содержится текст, а «В» — цифры. В качестве критерия поиска может использоваться определенный адрес ячейки с необходимым словом. Как вариант, его можно написать в необходимом месте. При этом расчет среднего значения производится для второй колонки.

Как посчитать средневзвешенное значение

Следующий вопрос — как вывести среднее значение в Excel для средневзвешенного параметра. Чтобы посчитать эти данные, потребуются функции СУММПРОИЗВ и СУММ. Для расчета средневзвешенного параметра используется следующая формула (пример):

=СУММПРОИЗВ(C2:C13;B2:B13)/СУММ(C2:C13).

Расчет в этом случае выполняется в два шага:

  1. СУММПРОИЗВ позволяет определить сумму.
  2. Применение СУММ позволяет определить общее количество каких-либо единиц, к примеру, реализованной продукции.

Расчет без игнорирования нулевых значений

Итого в Экселе приходится посчитать среднее значение столбцов с учетом нулевых параметров. В таком случае нужно использовать опции С AVERAGE и ЕСЛИ. При этом сам запрос может иметь следующий вид =С AVERAGEIF(A2:A7;"<>0").

Как видно из сказанного, посчитать среднее значение в Excel можно разными способами — через формулы, путем ввода ручные или с помощью мастера. При этом в некоторых случаях может потребоваться применение дополнительных функций.

В комментариях расскажите, пригодились ли вам указанные выше рекомендации, и какие еще методы можно использовать для решения поставленной задачи.